macOS のユーザーガイド

スクリーンショットに注釈を付けて、数秒でクリップボード、ディスク、シート共有、またはドラッグで送り返します。製品コンテンツはローカルのままです。サポート接続は明示的です。

このページは、Swift アプリの組み込みヘルプ (ヘルプ ▸ Draw On Clipboard ヘルプ、または ⌘/) から生成されるため、Web サイトとアプリは常に一致します。

開始方法

Draw On Clipboard はメニューバーに常駐します。一連の流れは 3 つのステップです。

1 — キャプチャ: ⌃⇧⌘4 を押して、任意の領域をドラッグします。これにより、クリップボードにコピーされます。(プレーンな ⇧⌘4 はファイルを保存するため、それも機能します。詳細については、「画像の取り込み」を参照してください)

2 — 開く: メニューバーの鉛筆アイコンをクリックするか、⌃⌥A を押します。キャプチャが描画を開始する準備が整います。

3 — 送信: マークアップし、コピー (⌘C) を押して、貼り付けたい場所 (Slack、Mail、ドキュメントなど) に貼り付けます。または、保存、共有、またはドラッグしてエクスポートします。

これだけです。このガイドの残りの部分はオプションの追加情報です。

メニューバーアイコンについて: 通常のクリックでクリップボード画像がすぐに開きます。これは高速な方法です。メニュー (過去のセッション、設定、ヘルプ) にアクセスするには、アイコンを 右クリック するか、⌥ キーを押しながらクリックします。

画像の取り込み

描画する画像を取得する方法はいくつかあります。最後の方法を除いて、特別な権限は必要ありません。

クリップボードから (主な方法)。 ⌃⇧⌘4、ブラウザの「画像をコピー」、Finder でコピーしたファイルなど、どんな画像でもコピーできます。その後、メニューバーのアイコンをクリックするか、⌃⌥A を押します。

ファイルを開く… (⌘O)。 PNG、JPEG、TIFF、HEIC、GIF、WebP、または PDF の最初のページを開くことができます。 保存した .docsession を開いて、過去の作業を再開することもできます。

ドラッグアンドドロップ。 画像ファイルを空の Draw On Clipboard ウィンドウにドラッグします。

Finder から。 画像を右クリックし、▸ Open With ▸ Draw On Clipboard を選択します。

空白の画像… スクリーンショットは不要です。白紙から始めます。 Small、Medium (ランドスケープまたはポートレート)、または Large スクエアを選択します。 ファイルメニュー、メニューバーのアイコンのメニュー、または空のウィンドウにあります。

新しいスクリーンショット。 アプリ内からスクリーンショットを取得します (メニューバー ▸ 新しいスクリーンショット)。 これは Screen Recording 権限が必要な唯一の方法です。問題が発生する場合は、トラブルシューティングを参照してください。

マルチフレームファイル (アニメーション GIF、マルチページの PDF/TIFF) は最初のフレームを読み込み、その旨をお知らせします。

描画ツール

すべてのツールにはワンキーショートカットがあります。ツールバーで現在選択されているツールが強調表示されます。

V — 選択。 オブジェクトをクリックして選択します。ドラッグして移動、角のハンドルをドラッグしてサイズ変更、⌘D で複製、⌫ で削除、矢印キーで微調整します。何かを選択した状態で色や幅を変更すると、スタイルが変更されます。

P — ペン。 フリーハンドで描きます。クリックすると点を作成します。

H — ハイライト。 半透明で、下にあるものと乗算されます。実際のマーカーのように。

L — 線 · A — 矢印 · R — 長方形 · O — 楕円。 ドラッグして描きます。図形はアウトラインのみです。

T — テキスト。 ボックスを配置して入力するにはクリックします。Return を押すと確定し、Esc を押すとキャンセルされます。⌥Return で新しい行を作成します。テキストは自動的に微妙なアウトラインを取得するため、どんな背景でも読みやすくなります。

N — 番号付きバッジ。 1、2、3… をドロップするにはクリックします。1 つを削除すると、残りのバッジは自動的に再番号付けされます。

X — 墨消し。 「機密情報を隠す」を参照してください。

C — 切り取り。 ボックスをドラッグし、Return を押すと適用され、Esc を押すとキャンセルされます。切り取りは単なるステップであるため、後で取り消すことができます。

⇧ を長押し すると制約されます。線と矢印は 45° にスナップし、長方形と楕円は正方形と円になります。

色と幅 はツールバーにあります。スライダーの横にあるドットは、現在のストローク幅のプレビューを表示します。どちらもセッション間で記憶されます。

拡大/縮小 は ⌘+ / ⌘− / ⌘0 で行います。または、トラックパッドでピンチ操作を行います。拡大/縮小は表示にのみ影響します。エクスポートは常にフル解像度です。

機密情報の隠蔽

Xツールは領域を隠蔽します。スタイルは2種類あり、違いが重要です。

ソリッド(デフォルト)。 不透明なブロックで、何も復元できません。パスワード、トークン、口座番号など、本当に重要なものにはこれを使用してください。

ピクセル化。 元の形状をほのめかす、粗いブロックです。見た目はきれいです。しかし、既知のフォントの既知のテキストの場合、攻撃者によってピクセル化が取り消される可能性があります。顔や一般的なごみには問題ありませんが、機密情報には適していません。

エクスポートで保証されていること: コピー、保存、共有、またはドラッグアウトするすべての画像は、フラットなレンダリングです。隠されたピクセルは本当に消去され、その下に重ねて表示されることはありません。エクスポートには、埋め込まれたサムネイル、残りのメタデータ、隠された末尾データは一切含まれていません。(最後の部分は、他のツールで「トリミングされた」スクリーンショットが有名なリークを引き起こした欠陥ですが、ここでは設計上除外されており、自動テストでカバーされています。)

正直な注意点: セッションがまだ開いている場合、または保存されている場合は、編集前の元の画像がセッションの自動保存に保持されます。これにより、取り消しができます。これはMacにのみ存在し、Time Machineなどのバックアップにコピーされる場合もあります。非常に機密性の高いキャプチャで、これが気になる場合は、ファイル ▸ セッションを今すぐ削除を使用してください。これにより、セッションの保存データが直ちに消去され、それ以上保存されなくなります。

履歴、元に戻す、分岐

ツールバーの下にあるストリップは履歴です。 変更ごとに 1 フレームが作成され、一番左は最も古いフレームで、「ベース」 (編集前の画像) から始まります。

元に戻す / 取り直す。 ツールバーの 2 つの矢印、または ⌘Z / ⇧⌘Z を使用します。

どこへでもジャンプ。 任意のフレームをクリックして、その時点まで巻き戻します。 フレームの上に少しマウスカーソルを合わせると、コミットすることなく拡大表示できます。

元に戻してから描画。 元に戻すとは、最後の変更が間違っていたことを意味するため、再度描画すると、取り消した手順が自動的に置き換えられます — 追加の質問はありません。

フレームをクリックしてから描画。 以前のタイムラインのフレームを選択すると、Draw On Clipboard は何かを破棄する前に確認を求めます:

現在の位置より後のフレームは薄く表示されます。これは、それらのフレームが破棄される可能性があることを示す合図です。

表示されている内容は、エクスポートされる内容と完全に一致します。 ステップ 3 に巻き戻してコピーすると、ステップ 3 の内容がコピーされます。

クリップボードバッジ。 コピーすると、フレームの隅に小さなオレンジ色のクリップボードマークが表示されます。 描き続け、そのマークはそのまま表示されます。これにより、最後にコピーしたバージョンを常に確認できます。 再びコピーすると、マークは新しいフレームに移動します。 (ここからコピーしたことをマークしますが、別のアプリで何かをコピーしたかどうかを知ることはできません。) 巻き戻してコピーしたステップの上に描画すると、そのバージョンは存在しなくなり、マークは消えます。

結果を取り出す方法

エクスポート方法として、以下の4つの方法があります。いずれも元の解像度と忠実な色を再現した画像を作成します(Retinaディスプレイのスクリーンショットは鮮明さを保ちます)。

コピー (⌘C): クリップボードに直接コピーし、すぐに貼り付けることができます。最も迅速な方法です。

保存… (⌘S): ディスクにファイルとして保存します。デフォルトではPNG形式で保存されますが、JPEG形式を選択することも可能です。デフォルトではデスクトップに保存され、最後に保存した場所を記憶します。

最初の2つの方法については、ツールバーまたはファイルメニューの画像コピー画像保存…からアクセスできます。

共有: 標準のmacOS共有シートを使用します。AirDrop、Mail、メッセージ、メモなど、さまざまな方法で共有できます。

ドラッグ&ドロップ: ツールバーの右端にある小さな画像チップをFinder、チャットウィンドウ、またはメールにドラッグします。最も迅速な方法の1つです。

これらのボタンの横にあるステータスチップは、常にエクスポートの状況を表示します。「エクスポートされていません」、「コピー済み ✓ 14:41」または最後にエクスポートしてから何か描画した場合、「エクスポート後に編集済み」と表示されます。ホバーすると、このセッションで行ったすべてのエクスポートを表示できます。

エクスポートせずにウィンドウを閉じると、最初に確認を求められます。また、「コピー&終了」では、両方の操作を1回のクリックで実行できます。セッションはその後も保持されます(「過去のセッション」を参照してください)。

過去のセッション

Draw On Clipboard は作業中に継続的に保存するため、ご心配ありません。アプリが終了したり、クラッシュしたり、誤ってウィンドウを閉じてしまったりした場合でも、作業は失われません。

再開するには: メニューバーのアイコンを右クリックし、過去のセッション ▸ を選択します。これにより、最新のセッションが最新順に表示されます。各セッションには、サイズ、最後に触れた日時、ステップ数などが表示されます。クリーンに閉じられなかったセッションは、「· 回復済」というタグが付いています。セッションを選択すると、完全に中断した状態から再開できます。フルタイムラインも、表示していたステップもそのままです。

クラッシュした場合、次回ウィンドウを開く際に回復したセッションが提供されることがあります。

セッションの保持期間: 14日間です。エクスポートしていない作業は、スペースを節約するために早期に削除されることはありません。エクスポートしたセッションの内容がすでにエクスポートされている場合のみ、トリミングできます。ただし、50個以上のセッションを超えてはなりません。

場所: ~/Library/Application Support/Draw On Clipboard/Sessions にあります。各セッションは .docsession バンドルとして保存されており、Finder でダブルクリックして再開したり、14日を超えて保持したい場合は安全な場所に移動したりできます。

あなたのデータとプライバシー

描画、スクリーンショット、クリップボードの内容、セッションはすべてデバイス内に保存されます。 アカウント、同期、分析機能はありません。ネットワークにアクセスするのは、フィードバックを明示的に送信したとき、「マイレポート」を開いたとき、または「その他のアプリ」を開いたときだけです。フィードバックで送信されるのは、入力した文章と確認画面に表示される互換性情報だけです。画像、パス、ファイル、ログ、クリップボードの内容は送信されません。「その他のアプリ」も互換性情報だけを送信し、開いたときにのみ動作します。

Macに保存されるもの:

• セッション — ~/Library/Application Support/Draw On Clipboard/Sessions (14日間保持)。これには、あなたが墨消しした内容も含めて、元の画像が含まれています。これにより、取り消し機能が動作します。

• 環境設定 — ツール、色、ホットキー、およびウィンドウの選択肢。

• プライベートなフィードバックレシート — My Reportsを開く際にのみ使用される不透明なレポート機能。

• 診断ログ — 標準的なmacOSログ。これらは自動的に期限切れになります。何が起こったかを記録するだけで、画像の内容や入力したテキストは記録しません。

エクスポートするファイルはあなたのものです。 Draw On Clipboardはそれらに一切触れません。「すべてのデータを消去」を実行しても削除されません。

削除する方法:

ファイル ▸ セッションを今すぐ削除 — このセッションの保存データを直ちに削除し(墨消しされていない元の画像も含む)、保存を停止します。ウィンドウは開いたままなので、完了してエクスポートできます。

My Reports ▸ 連絡先情報を削除 — そのレポートの検証されたオプションのメールアドレスを削除します。

設定 ▸ すべてのデータを消去 — 保存されたすべてのセッションを削除し、環境設定をリセットします。確認する前に、何が削除されるかを正確に示します。

アプリ全体を削除するには: アプリケーションフォルダからゴミ箱にドラッグし、上記のセッションフォルダとアプリの環境設定ファイルを削除してください。

キーボードショートカット

開始方法

⌃⇧⌘4 — クリップボードに領域をキャプチャ (macOS)

⌃⌥A — クリップボードの画像を Draw On Clipboard で開く

⌘N — クリップボードに注釈を付ける · ⌘O — ファイルを開く · ⌘W — ウィンドウを閉じる · ⌘, — 設定 · ⌘/ — このヘルプ

ツール

V 選択 · P ペン · H ハイライト · L 線 · A 矢印

R 長方形 · O 楕円 · T テキスト · N 番号付きバッジ · X 墨消し · C 切り取り

⇧ (保持) — 45° / 四角形 / 円形 に制約

編集

⌘Z 取り消す · ⇧⌘Z やり直す · ⌘D 選択を複製 · ⌫ 選択を削除 · 矢印キーで微調整

Return — 切り取り / テキストのコミット · Esc — 切り取り、テキスト、または選択をキャンセル · ⌥Return — テキスト内の新しい行

表示

⌘+ ズームイン · ⌘− ズームアウト · ⌘0 ウィンドウにフィット · ピンチでズーム

送信

⌘C コピー · ⌘S 保存… · ツールバーチップをドラッグしてドラッグでエクスポート

トラブルシューティング

「新しいスクリーンショット」でスクリーン録画の許可が必要と表示されます。

アプリ内でスクリーンショットを撮るには、macOSからその許可が必要です。システム設定 ▸ プライバシーとセキュリティ ▸ スクリーン録画 で Draw On Clipboard をオンにしてください。その後、Draw On Clipboard を終了して再度開いてください。すでに有効になっているように見えても、オフにしてから再度オンにすると、アップデート後に古い許可が残っている場合があります。 ⌃⇧⌘4 でキャプチャし、メニューバーのアイコンをクリックすることで、これらをすべてスキップできます。これには許可は必要ありません。

アイコンをクリックしても何も起こりません。

クリップボードにある画像を開きます。クリップボードに画像がない場合は、キャプチャ方法を説明するウィンドウが表示されます。メニューの上部を確認してください。常にクリップボードに何があるか表示されます。

メニューが見つかりません。

アイコンを通常クリックすると、すぐに注釈を付けることができます。 右クリック (または ⌥-クリック) でメニューを表示します。 より小型のMacBookでアイコンがノッチの背後に隠されている場合は、⌃⌥A を使用してください。

バナーに自動保存が失敗すると表示されます。

通常はディスクがいっぱいです。作業をコピーして (バナーにボタンが表示されます) 空き容量を確保してください。

どこに行ったのですか?

どこにも行っていません。 "過去のセッション" を確認してください。 メニューバーのアイコンを右クリック ▸ 過去のセッション。